Problems with R530 (Intel Graphics)

Everything else
lahdekorpi
Newbie
Newbie
Posts: 2
Joined: 30/11/2010, 10:15

Problems with R530 (Intel Graphics)

Postby lahdekorpi » 30/11/2010, 10:29

Hello!
I just bought a R530 (R530-JA08SE to be specific), and the first obvious thing was to install Ubuntu 10.10 (64bit).

But I'm having problems with (I'm assuming) Intel drivers. It's really sluggish, mouse keeps freezing all the time when something new is drawn into the screen. I've noticed that turning Compiz effects off helps a little, but it's still somewhat unusable.
When using the console (even if Xorg is running in the background) it works just fine.

I've already tried the kernel from voria ppa and installed bleeding edge Xorg from xorg-edgers ppa. Upgrading to xorg-edgers did help a tiny bit, but still, I can't use the machine.
I don't even care for 3D anymore, I just want to be able to surf the web and watch videos.

Any ideas on what should I try next? I would really appreciate any suggestions.

(Oh, and the brightness setting doesn't work, but there's an another topic about that already)

lspci:

Code: Select all

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller

lahdekorpi
Newbie
Newbie
Posts: 2
Joined: 30/11/2010, 10:15

Re: Problems with R530 (Intel Graphics)

Postby lahdekorpi » 30/11/2010, 12:30

Found a "solution" and posting it here if anybody else has the same issue.

There's a bug about this at https://bugs.launchpad.net/ubuntu/+sour ... bug/252094

Enabling UXA acceleration does make the problem go away, but it might have some stability issues (haven't found any yet).

Also forgot this on last post, lspci (with IDs):

Code: Select all

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 09)


Return to “Other”

Who is online

Users browsing this forum: No registered users and 3 guests