[DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Discussions about Linux installation and configuration on Samsung laptops
Post Reply
luke1337
Newbie
Newbie
Posts: 4
Joined: 25/01/2015, 5:11

[DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Post by luke1337 » 25/01/2015, 8:55

I've ported easy-slow-down-manager for Linux kernel 3.x.

Check this out and tell me if it doesn't work.

puntigamer
Newbie
Newbie
Posts: 1
Joined: 02/03/2015, 22:04

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.0

Post by puntigamer » 02/03/2015, 22:14

Hi! Thank you from porting this!

My problem is (Ativ Book 7), that after "silencing" the fan/cpu and use it for a while (even browsing starts the fan), it never goes back to the silence state, so I have to echo every time when I will silence it again. Why is this? It's not a good solution the echo 1 to esdm all the time, I guess :)

savimisha
Newbie
Newbie
Posts: 1
Joined: 24/01/2016, 18:13

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Post by savimisha » 24/01/2016, 18:38

Where is the attachment esdm.zip? It was here yesterday(

User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Post by voria » 24/01/2016, 19:16

There have been some problems during the forum migration, almost all of the old attachments have been corrupted. :(
Luckily, not this one. Here it is:
Attachments
esdm.zip
(4.81 KiB) Downloaded 177 times
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

luke1337
Newbie
Newbie
Posts: 4
Joined: 25/01/2015, 5:11

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Post by luke1337 » 17/04/2016, 12:01

Hi, this is the author of easy-slow-down-manager for Linux 3.x.

I've just confirmed that the attachment the admin has posted didn't get corrupted :)

By the way, I wonder if this works for Linux 4.x? I haven't tested it yet, since I haven't got a Linux 4.x kernel yet..

(The sure thing is, it does work on Ubuntu 14.04 LTS - the one I currently am using :P)

NitroNilz
Newbie
Newbie
Posts: 1
Joined: 07/06/2016, 11:54

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Post by NitroNilz » 07/06/2016, 12:05

I just tried it on a 4.5* kernel, but didn't get it working. I'm no x-pert and the error is probably that by trying to follow your instructions I downloaded the source of the 3.16-kernel while using 4.5.
Is there a way I could properly test it on my kernel?

Here's the trouble:

Code: Select all

# make -C /usr/src/linux-source-3.16 M='pwd' modules
make: Entering directory '/usr/src/linux-source-3.16'

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.


  WARNING: Symbol version dump ./Module.symvers
           is missing; modules will have no dependencies and modversions.

scripts/Makefile.build:44: pwd/Makefile: No such file or directory
make[1]: *** No rule to make target 'pwd/Makefile'.  Stop.
Makefile:1352: recipe for target '_module_pwd' failed
make: *** [_module_pwd] Error 2
make: Leaving directory '/usr/src/linux-source-3.16'

luke1337
Newbie
Newbie
Posts: 4
Joined: 25/01/2015, 5:11

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Post by luke1337 » 09/06/2016, 13:14

NitroNilz wrote:I just tried it on a 4.5* kernel, but didn't get it working. I'm no x-pert and the error is probably that by trying to follow your instructions I downloaded the source of the 3.16-kernel while using 4.5.
Is there a way I could properly test it on my kernel?

Here's the trouble:

Code: Select all

# make -C /usr/src/linux-source-3.16 M='pwd' modules
make: Entering directory '/usr/src/linux-source-3.16'

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.


  WARNING: Symbol version dump ./Module.symvers
           is missing; modules will have no dependencies and modversions.

scripts/Makefile.build:44: pwd/Makefile: No such file or directory
make[1]: *** No rule to make target 'pwd/Makefile'.  Stop.
Makefile:1352: recipe for target '_module_pwd' failed
make: *** [_module_pwd] Error 2
make: Leaving directory '/usr/src/linux-source-3.16'
I haven't checked the 4.x versions yet. Maybe I will port it to 4.x version later ;)

EDIT: I think there's something wrong with your setup according to that error message...maybe the Linux source code tree wasn't configured (by `make oldconfig` or such)?

Post Reply