active WLAN produces noise on headphone

Discussions about Linux installation and configuration on Samsung laptops
nikgid
Newbie
Newbie
Posts: 3
Joined: 12/05/2009, 20:24

active WLAN produces noise on headphone

Postby nikgid » 12/05/2009, 20:37

Hi folks,

I wanted to ask if some of you have the same problem:

When I have an active WLAN connection and data is transeferred (loading a webpage), some quite annyoing and loud crackling sound is produced - I can only hear it on the headphone... so I guess it is only produced on the headphone jack. I have crystal clear audio without unwanted noise while listening to mp3 files from my harddisk and while WLAN is inactive.

I am running Ubuntu 9.04, kernel 2.6.28-11 (the latest default-kernel) on my Samsung NC10 (model with BT but without UMTS).

Maybe it has something to do with IRQs?! But where could I change them. Found nothing in the BIOS.

Help please! I would really like to solve this because it makes listening to music over headphones while surfing via WLAN quite unpleasant.

Cheers,
Niklas

kadrach
Newbie
Newbie
Posts: 30
Joined: 14/03/2009, 21:59

RE: active WLAN produces noise on headphone

Postby kadrach » 12/05/2009, 23:00

Most likely your headphones are not shielded. You are picking up a GSM/EDGE/IEEE802.11 radio frequency.

Solution: Try headphones with shielded wires.
Last edited by kadrach on 12/05/2009, 23:02, edited 1 time in total.

nikgid
Newbie
Newbie
Posts: 3
Joined: 12/05/2009, 20:24

RE: active WLAN produces noise on headphone

Postby nikgid » 13/05/2009, 15:20

'kadrach' pid='1129' dateline='1242165609' wrote:Most likely your headphones are not shielded. You are picking up a GSM/EDGE/IEEE802.11 radio frequency.

Solution: Try headphones with shielded wires.


Thanks for the suggestion! But sadly, it doesn't seem to work. I tried 4 different types of headphones - among them at least two of very good quality (Grado SR80, Etymotics ER4P, and then Koss Porta Pros and some cheapo Sony earbuds). All of them had the same funny noises.

So if it would have to do something with unshielded headphones, then I suspect that many people would be able to reproduce this symptom of headphone noise during wireless activity. Maybe some other forum users can confirm or tell if its the same with their NC10?

And the noises are very clearly connected to activity on the WLAN - they only are there, while _loading_ a youtube-video for example. As soon as all the data of the video is loaded, the noise stops. So that would speak against the noise being sourced by GSM/EDGE/..., right?

Hoping for further help/ideas,
Niklas

EDIT: tested this under Windows (I am keeping a dual-boot still) - the noise is there, but it is _much_ more silent, almost unnoticable - not disturbing at all... have to crank up the volume to the max to be able to hear it (and then the music is unbearably loud with my etymotics headphones :-).

So... this is most definitely a Software(Linux)-issue. (Which I am happy for... at least it's not defect hardware.)
Last edited by nikgid on 13/05/2009, 18:10, edited 1 time in total.

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: active WLAN produces noise on headphone

Postby voRia » 13/05/2009, 18:19

Mmm, I have no problems at all on my NC10, using cheap sony headphones. Audio is always clear, even when I use the wireless card.

EDIT:
What about the internal microphone? It may be the cause of the noise. Check if it's enabled, if so try disabling it.
Last edited by voRia on 13/05/2009, 18:22, edited 1 time in total.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest