NC10 / VGA-out Issues

Discussions about Linux installation and configuration on Samsung laptops
kadrach
Newbie
Newbie
Posts: 30
Joined: 14/03/2009, 21:59

NC10 / VGA-out Issues

Postby kadrach » 01/05/2010, 20:38

Hey, I need some pointers on troubleshooting ext Vga out issues.

I had dual screen set up using xrandr, and didn't fuck with it otherwise.

Just a few hours ago, the external screen went "blank", but it is still receiving a signal, and the desktop is still there, ie i can move the mouse pointer onto it. But the monitor is just blank.

Resetting/restarting, reconfiguring xrandr etc DID NOT help. Also, no errors as far as I can tell in xsessions, Xorg.0.log, syslog and dmesg.

Anyone got an idea of whats going on?

EDIT: Also, cloning output does not help, monitor stays blank.

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: NC10 / VGA-out Issues

Postby voRia » 02/05/2010, 17:09

Are you using Karmic?
If so, the problem is caused by compiz, then you have to disable it before enabling the vga out.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

kadrach
Newbie
Newbie
Posts: 30
Joined: 14/03/2009, 21:59

Re: NC10 / VGA-out Issues

Postby kadrach » 02/05/2010, 17:15

I started with Hardy, no compiz. Worked fine, then suddenly, bam, nothing works.

Have now upgraded to Lucid, still does not work, neither with compiz nor metacity. Problem is definitely X related.

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: NC10 / VGA-out Issues

Postby voRia » 03/05/2010, 19:12

That's strange, on my NC10 the VGA out works as expected out-of-the-box (using Lucid).
Are you sure it's not an hardware problem? Do you have another OS (like windows) installed to test if the VGA out works with it?
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

kadrach
Newbie
Newbie
Posts: 30
Joined: 14/03/2009, 21:59

Re: NC10 / VGA-out Issues

Postby kadrach » 05/05/2010, 16:53

It does work with a live cd. So definitely not hardware related. But why the hell wont a restart fix it? The problem must lie in some part of the system that is saved/restored on reboot. The last thing I recall happening is the monitor/desktop slowly fading/blanking as if it was about to enter screensaver mode.

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: NC10 / VGA-out Issues

Postby voRia » 06/05/2010, 17:23

Perhaps you are using a custom xorg.conf file which may have broke vga out support?
If so, try to remove it. Also, just to be sure, create a new temp user and try to enable the VGA out with it.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests