Page 6 of 6

Re: Backlight doesn't work with latest Maverick kernel

Posted: 19/03/2011, 17:12
by jazz
dundee wrote:Hello,
I'm owner of Samsung NP-N150-JP01PL.
In my case after installing samsung-backlight and samsung-tools I use following sollution with success:

1. edit /etc/default/grub

Code: Select all

sudo nano /etc/defautl/grub
2. change line from

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
3. update grub

Code: Select all

sudo update-grub2
4. create file /etc/modprobe.d/samsung-backlight.conf

Code: Select all

sudo nano /etc/modprobe.d/samsung-backlight.conf
5. insert into this file following line and save it

Code: Select all

options samsung_backlight use_sabi=0 force=1
6. reboot the system

This solution was checked under GNOME and KDE and in both it works perfectly.
Naturally you can use your favourite text editor instead of nano.
I could only set the brightness to the min or max with the backlight keys on my NF-310, I tried everything on this thread, with no success, but with your solution it finally works! Thanks!

Re: Backlight doesn't work with latest Maverick kernel

Posted: 23/03/2011, 9:12
by Woulouf
jazz wrote:
dundee wrote:Hello,
I'm owner of Samsung NP-N150-JP01PL.
In my case after installing samsung-backlight and samsung-tools I use following sollution with success:

1. edit /etc/default/grub

Code: Select all

sudo nano /etc/defautl/grub
2. change line from

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
3. update grub

Code: Select all

sudo update-grub2
4. create file /etc/modprobe.d/samsung-backlight.conf

Code: Select all

sudo nano /etc/modprobe.d/samsung-backlight.conf
5. insert into this file following line and save it

Code: Select all

options samsung_backlight use_sabi=0 force=1
6. reboot the system

This solution was checked under GNOME and KDE and in both it works perfectly.
Naturally you can use your favourite text editor instead of nano.

I could only set the brightness to the min or max with the backlight keys on my NF-310, I tried everything on this thread, with no success, but with your solution it finally works! Thanks!
And you don't encounter issues like flickering screen with brightness level going up and down quickly ?

Thanks

Re: Backlight doesn't work with latest Maverick kernel

Posted: 26/03/2011, 14:56
by jazz
Woulouf wrote: And you don't encounter issues like flickering screen with brightness level going up and down quickly ?
Not anymore! Now the screen dims correctly after some time of inactivity.

Re: Backlight doesn't work with latest Maverick kernel

Posted: 26/03/2011, 20:23
by minj
dundee wrote:Hello,
I'm owner of Samsung NP-N150-JP01PL.
In my case after installing samsung-backlight and samsung-tools I use following sollution with success:

1. edit /etc/default/grub

Code: Select all

sudo nano /etc/defautl/grub
2. change line from

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
3. update grub

Code: Select all

sudo update-grub2
4. create file /etc/modprobe.d/samsung-backlight.conf

Code: Select all

sudo nano /etc/modprobe.d/samsung-backlight.conf
5. insert into this file following line and save it

Code: Select all

options samsung_backlight use_sabi=0 force=1
6. reboot the system

This solution was checked under GNOME and KDE and in both it works perfectly.
Naturally you can use your favourite text editor instead of nano.
Confirmed on NF310.

Although after some fiddling around with power state, lid and suspend/hibernate cycles I managed to make plugging cable out cause 'closed lid' action, which is very annoying if it is set to suspend. After a proper reboot the glitch didn't repeat itself though. I don't really want to reproduce it ;)

Re: Backlight doesn't work with latest Maverick kernel

Posted: 01/04/2011, 21:41
by Sam66
Thank you everybody !

I have tried to add the command acpi_backlight=vendor in my Grub and it's all right, I have recovered my Fn brightness buttons in the 2.6.35-28 kernel.

Great !

Re: Backlight doesn't work with latest Maverick kernel

Posted: 04/04/2011, 2:04
by terry
Passing the kernel parameter acpi_backlight=vendor does the trick on N-148.

However, I did see weird issues running on battery, after idling for a few seconds system tries to adjust the brightness itself back and forth flickering for 20-30 times, unchecking the dim display when idle fixed it.

Good to see it's been such a long post, in fact I haven't used my netbook for a while...

Re: Backlight doesn't work with latest Maverick kernel

Posted: 15/04/2011, 9:24
by pawel115
I am total newbie to Ubuntu i did all above instructions and nothing the only change that i see is that when i press Fn + up/down brightness level doesnt show like it did before i have samsung n145

Re: Backlight doesn't work with latest Maverick kernel

Posted: 29/06/2011, 15:49
by robbie66
I have posted a new thread because I find all this tech stuff really hard to follow, is there a Dummies guide??!!

http://www.voria.org/forum/viewtopic.ph ... 220+screen

Re: Backlight doesn't work with latest Maverick kernel

Posted: 12/07/2013, 21:45
by lfc84
this works on samsung n210plus

Linux N150P-N210P-N220P 3.2.0-49-generic-pae #75-Ubuntu SMP Tue Jun 18 18:00:21 UTC 2013 i686 i686 i386 GNU/Linux