Brightness problem

Discussions about Linux installation and configuration on Samsung laptops
Post Reply
Posts: 1
Joined: 23/11/2011, 16:56

Brightness problem

Post by Qhorin » 23/11/2011, 17:00

Hi all, I've just installed Backtrack 5 R1 on my Samsung R780 laptop. At first I wasn't able to use any of the Fn combinations, but now I can use all of them except for the brightness one. I cannot set it with Brightness Applet, too. I've looked for a solution over the internet and so I installed hotkey and samsung tools. The first doesn't work with the brightness combination, and the second seems not to work at all, and if I try to run it in system/preferences/samsung tools preferences it says starting samsung... but then nothing happens. I've tried to modify the grub file, but i only managed to get the brightness to the maximum level. I'll post you my grub file text in order to help

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux acpi_backlight=vendor splash"
GRUB_CMDLINE_LINUX="quiet splash"

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
I hope you can help me to find a solution to this annoying problem. I apologize for any grammatical error I made, cause I'm not English...

Post Reply