no wifi...

Discussions about Linux installation and configuration on Samsung laptops
micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

no wifi...

Postby micha » 19/09/2009, 13:27

hello,

I tried your repository with my nc10. But the Fn F9-Key does not work correctly! Trying

Code: Select all

sudo nc10 wifi on

in the terminal, I get some error-messages:

Code: Select all

mk@mk-netbook:~$ nc10 wifi
Access Denied - You must be root to perform this operation
mk@mk-netbook:~$ sudo nc10 wifi
WARNING: Error inserting led_class (/lib/modules/2.6.28-15-generic/kernel/drivers/leds/led-class.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting lbm_cw_mac80211 (/lib/modules/2.6.28-15-generic/updates/lbm_cw-mac80211.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting ath5k (/lib/modules/2.6.28-15-generic/updates/ath5k.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Funknetzwerk - Funknetzwerk ausgeschaltet

Please help me, without your help I can't get online with my netbook!

Micha
(Please excuse my bad english - I know, it's awful!)

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: no wifi...

Postby voRia » 19/09/2009, 13:32

Did you install the 'linux-backports-modules-jaunty' package? If so, restart the system.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 19/09/2009, 13:49

voRia wrote:Did you install the 'linux-backports-modules-jaunty' package? If so, restart the system.

I think, I did install it, but I'm not sure. Now I can't install anything, because I can't get online with the nc10...

I restarted the system: Now I don't get the error message.
Fn F9 seems to work. But the nc10 don't shows any wlan, even if wifi is on.

What to do now?

Micha

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: no wifi...

Postby voRia » 19/09/2009, 14:01

Use this command

Code: Select all

iwconfig

and check if 'wlan0' is listed. If so, then the wireless card should be up and running.

Then, try to manually scan for wireless lans, using the command:

Code: Select all

sudo iwlist wlan0 scan

Every 'Cell' section is a found wlan.
The same wlans should be available through the network manager applet in your systray.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 19/09/2009, 14:06

voRia wrote:Use this command

Code: Select all

iwconfig

and check if 'wlan0' is listed. If so, then the wireless card should be up and running.

It's not listed. Only lo, eth0, pan0 (always with "no wireless extensions.")

Micha

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: no wifi...

Postby voRia » 19/09/2009, 14:13

mmm, that's strange.

Try to remove then reinsert the ath5k module, with these commands:

Code: Select all

sudo modprobe -r ath5k
sudo modprobe ath5k

and check again if the 'wlan0' is created.
If it's not, check in your dmesg if there is any error explaining what's wrong.

Also, paste here the output of the command:

Code: Select all

lspci | grep Ethernet
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 19/09/2009, 14:32

voRia wrote:mmm, that's strange.

Try to remove then reinsert the ath5k module, with these commands:

Code: Select all

sudo modprobe -r ath5k
sudo modprobe ath5k

and check again if the 'wlan0' is created.


No, that changes nothing.

voRia wrote:If it's not, check in your dmesg if there is any error explaining what's wrong.


Perhaps it's this:

Code: Select all

[ 1623.976562] ath5k 0000:02:00.0: enabling device (0000 -> 0002)
[ 1623.976578] ath5k 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 1623.976599] ath5k 0000:02:00.0: setting latency timer to 64
[ 1623.976720] ath5k 0000:02:00.0: registered as 'phy0'
[ 1623.986789] ath5k phy0: failed to wakeup the MAC Chip
[ 1623.986853] ath5k 0000:02:00.0: PCI INT A disabled
[ 1623.986881] ath5k: probe of 0000:02:00.0 failed with error -5


You find the whole output of dmesg in this file: http://www.bm-kuehn.de/temp/errors.txt (can't attach files here in the board).

voRia wrote:Also, paste here the output of the command:

Code: Select all

lspci | grep Ethernet


Code: Select all

mk@mk-netbook:~$ lspci |grep Ethernet
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 13)


Thanks for more help...!

Micha

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: no wifi...

Postby voRia » 19/09/2009, 14:55

Looking at your dmesg, it seems that the 'ath_hal' and 'ath_pci' modules get loaded during the boot process.
I'm pretty sure this is the problem.
The above modules initialize the wireless card and leave it in a state that the 'ath5k' can't recover from.

The solution is to add these lines to your '/etc/modprobe.d/blacklist.conf' in order to avoid automatic loading:

Code: Select all

blacklist ath_pci
blacklist ath_hal

Let me know if this solves the problem. ;)
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 19/09/2009, 18:39

voRia wrote:Let me know if this solves the problem. ;)

I was offline for some hours...
Yes, it works now! Thank you very much! :P

Micha

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: no wifi...

Postby voRia » 19/09/2009, 18:44

good :D

PS: welcome to the forum ;)
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 19/09/2009, 19:58

voRia wrote:good :D

No, it's not so good... After another reboot, it does not work again.
The blacklist.conf is unchanged...

What can I do now?

Micha (going offline in a few minutes... answers tomorrow)

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 20/09/2009, 13:18

Here is what I did yesterday before I had the problem again:

I installed RandR and tried the Fn F4-Key - it works fine!
Then I installed nc10-fb for the new logo. I restarted the system for have a look at the logo (works fine - thank you)! But now there is no wlan recognized. It seems to be the same problem like before, iwconfig doesn't lists any Wlan0.

The output of dmesg is now here: http://www.bm-kuehn.de/temp/090920-dmesg.txt

Any ideas? It would be great to use the wlan tomorrow...!

Micha

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: no wifi...

Postby voRia » 20/09/2009, 17:31

Did you install the madwifi drivers manually?
I ask because ubuntu jaunty does not ship them by default, so they should not be installed.

Looking at your dmesg, it seems that no ath* module get loaded automatically at boot. While this is normal for 'ath_pci' and 'ath_hal' (you blacklisted them), the 'ath5k' should be loaded instead.
If it's not, the only cause I can think of is that the madwifi created some aliases during its installation, "linking" the wireless card to the 'ath_pci' and 'ath_hal' modules, ovverriding the default 'ath5k'.

So, make sure to completely uninstall the madwifi with the command 'sudo make uninstall' from within its sources directory.

PS: In the meanwhile, you should be able to use the wireless card by loading manually the 'ath5k' module.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 20/09/2009, 19:57

voRia wrote:Did you install the madwifi drivers manually?
I ask because ubuntu jaunty does not ship them by default, so they should not be installed.

Yes, I did. That was the first thing I installed in May, while testing ubuntu 9.04. The original drivers did not work with the NC10.

voRia wrote:So, make sure to completely uninstall the madwifi with the command 'sudo make uninstall' from within its sources directory.

How can I find this folder? And is your driver active after uninstalling madwifi?

voRia wrote:PS: In the meanwhile, you should be able to use the wireless card by loading manually the 'ath5k' module.

How can I load it? (I'm really new at linux...)
Thanks!

Micha

micha
Newbie
Newbie
Posts: 17
Joined: 19/09/2009, 13:14

Re: no wifi...

Postby micha » 20/09/2009, 20:51

micha wrote:How can I find this folder?

I searched for madwifi and found only two files: madwifi.py and madwifi.pyc both in /usr/share/jockey/handlers/.
"sudo make uninstall" does not work (in german: make: *** Keine Regel, um "uninstall" zu erstellen. Schluss", means: no rule for "uninstall". Finish.)
A "sudo make uninstall madwifi" does not work, too (same error).

Hm. You see, I need more help - for a linux newbie.

Micha


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: Baidu [Spider], Yahoo [Bot] and 5 guests