[NC10] Kernel 2.6.31

Discussions about Linux installation and configuration on Samsung laptops
roberfox
Newbie
Newbie
Posts: 1
Joined: 10/09/2009, 17:09

RE: [NC10] Kernel 2.6.31

Postby roberfox » 10/09/2009, 17:24

I have had to deal with a strange behavior. When I tried to use a kernel 2.6.3* (installed through nc10-kernel package), I got a black screen when gdm was supposed to start, so I could not start a session (no login screen) nor connect to any virtual console. A bit strange, because if I started from grub with "recovery mode" option, and later select "resume" from the menu, then everything worked OK (gdm's login screen and so on).

After some tests, I managed to make it work by uninstalling 'nc10-fb' package.

Hope this helps someone

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: [NC10] Kernel 2.6.31

Postby voRia » 10/09/2009, 17:38

That's strange. I'm using 'nc10-fb' with both 2.6.28 and 2.6.31 kernels with no problems at all.
Just in case, try to rebuild initramfs images, with this command:

Code: Select all

sudo update-initramfs -c -kall


Which intel driver are you using?
Last edited by voRia on 10/09/2009, 20:30, edited 1 time in total.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: [NC10] Kernel 2.6.31

Postby voRia » 11/09/2009, 1:42

Kernel version 2.6.31-10 updated on the repository, now it's based on vanilla 2.6.31 final.
Last edited by voRia on 11/09/2009, 1:43, edited 1 time in total.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

phelcq
Newbie
Newbie
Posts: 1
Joined: 26/05/2009, 13:29

Re: RE: [NC10] Kernel 2.6.31

Postby phelcq » 17/09/2009, 12:21

voRia wrote:Kernel version 2.6.31-10 updated on the repository, now it's based on vanilla 2.6.31 final.


I have just updated to that kernel version. Now Audacity freezes when I try to record sth, I mean it sort of starts recording and the process freezes after a very short while. You can close it though without any problems.

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: [NC10] Kernel 2.6.31

Postby voRia » 26/09/2009, 12:10

New kernel 2.6.31-11 on repository (based on vanilla 2.6.31.1).
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

cragg.
Newbie
Newbie
Posts: 31
Joined: 03/10/2009, 11:40

Re: [NC10] Kernel 2.6.31

Postby cragg. » 03/10/2009, 11:49

Hey community.

First I have to say that it is great, VoRia, that you are the one who supports Ubuntu on a NC10. I like that pretty much! :D

But now, after using your repository for a long term, I have a problem I can't solute.
When Ubuntu Jaunty wants to get the latests kernel-headers (2.6.31-11), I permit the installation. But after downloading the file, Ubuntu tells me that there is a problem installing the header because there is a problem with the dependences of a package "nc10-kernel"!
Because of that broken dependency I cannot install any package any more because Synaptic tells me I have to repair the broken dependency.

What shall I do? :(
Greets,
cragg. :)

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: [NC10] Kernel 2.6.31

Postby voRia » 03/10/2009, 12:58

Hello,
the latest 'nc10-kernel' on my repository has all its dependencies satisfied.
Make sure to update packages' indexes by running the command

Code: Select all

sudo apt-get update

then you should be able to perform a complete update with the command

Code: Select all

sudo apt-get dist-upgrade
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

cragg.
Newbie
Newbie
Posts: 31
Joined: 03/10/2009, 11:40

Re: [NC10] Kernel 2.6.31

Postby cragg. » 03/10/2009, 20:54

I tried "update" and "dist-upgrade" but when I do "sudo apt-get dist-upgrade" then the terminal tell me that "linux-headers-2.6.31-11-lpia" cannot be installed and that the package "nc10-kernel" depends on " linux-headers-2.6.31-11-generic" but " linux-headers-2.6.31-11-generic" isnt installed and Synaptic is not able to install these two linux-headers.

I'm sorry that I ask you again but I have no solution for that problem.
Could you please help me?

cragg. :)

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: [NC10] Kernel 2.6.31

Postby voRia » 04/10/2009, 0:09

That's strange.
Is there any reason specified why 'linux-headers-2.6.31-11-lpia' cannot be installed?

Anyway, try to download the package manually from the repository and install it using the command:

Code: Select all

sudo dpkg -i linux-headers-2.6.31-11-lpia_2.6.31-11.38~ppa1~nc10~jaunty_lpia.deb

If 'dpkg' does not install the package and prints any error, please paste here its complete output.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

cragg.
Newbie
Newbie
Posts: 31
Joined: 03/10/2009, 11:40

Re: [NC10] Kernel 2.6.31

Postby cragg. » 04/10/2009, 9:04

Yeah, I have an error.

When I tried to install

Code: Select all

sudo dpkg -i linux-headers-2.6.31-11-lpia_2.6.31-11.38~ppa1~nc10~jaunty_lpia.deb


my Netbook wasn't able to get it from your repository and neither could get access to your website.
Well, I dowloaded it manually from your-launchpad-site (/pool/main/linux/) but the installer told me, that there is a broken dependency (it's the package "nc10-kernel") and because of that there cannot be installed anything more until the problem is soluted.
So, then I try to remove the broken package and now WITHOUT any broken packages to install

Code: Select all

sudo dpkg -i linux-headers-2.6.31-11-lpia_2.6.31-11.38~ppa1~nc10~jaunty_lpia.deb


manually then the Installer says: "Error: Incorrect System-architecture"

Linux kernel headers for version 2.6.31 on Intel Atom processors
This package provides kernel header files for version 2.6.31 on Intel Atom processors.
This is for sites that want the latest kernel headers.
Please read /usr/share/doc/linux-headers-2.6.31-11/debian.README.gz for details.


But I HAVE a Samsung Nc10 WITH an intel Atom... I don't understand that.

Well, sometimes the Terminal tells me that "there is adisk full error" but I have about 600MB space left. That cannot be the problem, can it?

Greets,
cragg. :)

cragg.
Newbie
Newbie
Posts: 31
Joined: 03/10/2009, 11:40

Re: [NC10] Kernel 2.6.31

Postby cragg. » 04/10/2009, 12:06

Another thing.

As I cannot install the new kernel-stuff, VirtualBox reclaims that there is an error compiling the kernel.
See:

Error! Your kernel source for kernel 2.6.31-11-generic cannot be found at
/lib/modules/2.6.31-11-generic/build or /lib/modules/2.6.31-11-generic/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.
Failed to install using DKMS, attempting to install without
Makefile:147: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.


Maybe you can now see where the problem is? Hope, that there is any solution for my problem.

Thank you very much, VoRia!!! :)

cragg.

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: [NC10] Kernel 2.6.31

Postby voRia » 04/10/2009, 12:30

So, you are using i386 architecture, then you need the -generic packages, not lpia.
Download this and this packages, put them in the same directory. Open a terminal and move to the above directory, then use this command to install both of them:

Code: Select all

sudo dpkg -i *deb

If dpkg fails, please past here its complete output.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

cragg.
Newbie
Newbie
Posts: 31
Joined: 03/10/2009, 11:40

Re: [NC10] Kernel 2.6.31

Postby cragg. » 04/10/2009, 12:32

I do not understand. Which packages shall I download and where shall I download them? Sorry, I am a completely newby. :S

cragg.
Newbie
Newbie
Posts: 31
Joined: 03/10/2009, 11:40

Re: [NC10] Kernel 2.6.31

Postby cragg. » 04/10/2009, 12:38

So, now I will download these packages from Synaptic:

linux-headers-2.6.31-11
linux-headers-2.6.31-11-386
linux headers-2.6.31-11-generic
linux headers-2.6.31-11-generic-pae


We'll see... I tell you the results. :)

Edit: a lot of paths cannot be created :( So these packages couldnt been installed :(

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: [NC10] Kernel 2.6.31

Postby voRia » 04/10/2009, 13:20

cragg. wrote:I do not understand. Which packages shall I download and where shall I download them? Sorry, I am a completely newby. :S

There are two links on my previous message:
voRia wrote:...Download this and this packages...

You only need 'linux-headers-2.6.31-11' and 'linux-headers-2.6.31-11-generic'. Ignore the others.

Try to install them with dpkg, if it fails paste here the complete output.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: No registered users and 3 guests