fans always on

Discussions about Linux installation and configuration on Samsung laptops
kinlas
Newbie
Newbie
Posts: 2
Joined: 29/07/2009, 16:51

fans always on

Postby kinlas » 29/07/2009, 17:30

On my new nc10 with UNR + laptop-mode activated + powersave govern I still have fans always on. Is this normal behavior?

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: fans always on

Postby voRia » 17/08/2009, 9:33

Usually, what is your CPU temperature?
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

kinlas
Newbie
Newbie
Posts: 2
Joined: 29/07/2009, 16:51

Re: fans always on

Postby kinlas » 22/11/2009, 20:51

I no longer have this laptop (I only had to install it) so I won't be able to give precise temperature. I think the problem was with the table that allowed little dissipation. On other sufaces, there was no problem.

dochmeins
Newbie
Newbie
Posts: 2
Joined: 21/11/2009, 23:23

Re: fans always on

Postby dochmeins » 23/11/2009, 10:53

I have the same problem (fan is always on). Temperature is around 45°C.
CPU is usually at 1600MHz, even when there's only Pidgin and OpenOffice open.

User avatar
voRia
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: fans always on

Postby voRia » 24/11/2009, 20:00

Strange, my CPU temperature is 46°C at the moment and the fan is off (well, I think so, i hear no noise). What BIOS are you using?
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

dochmeins
Newbie
Newbie
Posts: 2
Joined: 21/11/2009, 23:23

Re: fans always on

Postby dochmeins » 25/11/2009, 14:04

Newest one, 11CA.

Kizikhi
Newbie
Newbie
Posts: 7
Joined: 04/04/2011, 13:41

Re: fans always on

Postby Kizikhi » 04/04/2011, 14:05

Hi, I have the same problem, my fan is allways on. I can control it, but it allways spining. My temperature is 39°C and the fan is allways spining in normal mode.
If I wouldn't change the fan mode by myself in commandline using the command

Code: Select all

samsung-tools --cpu silent/normal/cycle
it will keep spinning all the time. In my BIOS fan speed is set auto. I am using Ubuntu 11.04 on Samsung R530, in the last version 10.10 everything was ok, yestarday I've installed the 11.04 beta2 and got this problem. I've already reinstalled all applications (easy-slow-down-manager, xbindkeys, samsung-tools), but no effect, it's still always spinning. :( Please could you give me an advise to resolve this problem?

Here is some information:

Code: Select all

svaleri@valeri:~$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:       +39.0°C  (crit = +98.0°C)                 
temp2:       +39.0°C  (crit = +98.0°C)

User avatar
Woulouf
Supporter
Supporter
Posts: 51
Joined: 05/03/2011, 12:32
Location: France

Re: fans always on

Postby Woulouf » 04/04/2011, 14:11

Hi.

Downgrade to 10.10 and stop using beta versions if you don't want to bring bugs in your operating system.
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753

Kizikhi
Newbie
Newbie
Posts: 7
Joined: 04/04/2011, 13:41

Re: fans always on

Postby Kizikhi » 04/04/2011, 14:16

Woulouf wrote:Hi.

Downgrade to 10.10 and stop using beta versions if you don't want to bring bugs in your operating system.

But I think that in stable version the problem will remain. Isn't it better to resolve it now?

User avatar
Woulouf
Supporter
Supporter
Posts: 51
Joined: 05/03/2011, 12:32
Location: France

Re: fans always on

Postby Woulouf » 04/04/2011, 14:26

Whatever your think it's still a beta version.
You know what does it mean ?
You know also that something right with beta 1 could be broken with beta 2 ?

Problem here is not the computer or OS, it's the user.

Seriously, i mean, we don't even know if Voria got the time to test 11.04 and work on some modifications on the new kernel and samsung packages.

We already have some issues with ubuntu 10.04 and 10.10 and you, you come on these boards "hey guys, i didn't want to wait so i installed ubuntu 11.04 BETA. Omg, it sucks now 'cause it was better with 10.10, please work on a solution now".

You want to solve the problem ? Fine.

Contact Voria and give him some help, or you can also wait.
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753

Kizikhi
Newbie
Newbie
Posts: 7
Joined: 04/04/2011, 13:41

Re: fans always on

Postby Kizikhi » 04/04/2011, 15:40

Woulouf wrote:Whatever your think it's still a beta version.
You know what does it mean ?
You know also that something right with beta 1 could be broken with beta 2 ?

Problem here is not the computer or OS, it's the user.

Seriously, i mean, we don't even know if Voria got the time to test 11.04 and work on some modifications on the new kernel and samsung packages.

We already have some issues with ubuntu 10.04 and 10.10 and you, you come on these boards "hey guys, i didn't want to wait so i installed ubuntu 11.04 BETA. Omg, it sucks now 'cause it was better with 10.10, please work on a solution now".

You want to solve the problem ? Fine.

Contact Voria and give him some help, or you can also wait.

It's really strange, but after third reboot it works normally, but I am still going to reinstall 10.10. Too many bugs on 11.04. Sorry if I took your time.

User avatar
Woulouf
Supporter
Supporter
Posts: 51
Joined: 05/03/2011, 12:32
Location: France

Re: fans always on

Postby Woulouf » 04/04/2011, 15:48

If you really want to test unstable releases safely, use a virtual disk (Virtual box) or an another hard disk.

http://doc.ubuntu-fr.org/virtualbox
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753

Kizikhi
Newbie
Newbie
Posts: 7
Joined: 04/04/2011, 13:41

Re: fans always on

Postby Kizikhi » 05/04/2011, 22:40

Woulouf wrote:If you really want to test unstable releases safely, use a virtual disk (Virtual box) or an another hard disk.

http://doc.ubuntu-fr.org/virtualbox

You know, today I've reinstalled Ubuntu on Linux Mint 10 "Julia" and Samsung Tools works on it perfectly. No bugs with Fn keys at all, it worked in Ubuntu irregularly. And the main thing for which I am warried - fan, it works now as it should. Always fan was on only in Ubuntu.

I think my Ubuntu simply were installed with some corruptions.

As I understood here is one important thing. If I want the fan should work in cycle (accelerate and decelerate the rotation automatically by itself), I should turn it on in the cycle mode by command

Code: Select all

samsung-tools --cpu cycle
Am I right?

User avatar
Woulouf
Supporter
Supporter
Posts: 51
Joined: 05/03/2011, 12:32
Location: France

Re: fans always on

Postby Woulouf » 06/04/2011, 9:04

Kizikhi wrote:
Woulouf wrote:
As I understood here is one important thing. If I want the fan should work in cycle (accelerate and decelerate the rotation automatically by itself), I should turn it on in the cycle mode by command

Code: Select all

samsung-tools --cpu cycle
Am I right?


I think so but i 've never tested this option.

It could be useful to manage noise fan.

I know that even if i put my netbook in silent mode, speedfan will automatically increase if CPU Temp is too high, at least above a certain threshold.
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753

Kizikhi
Newbie
Newbie
Posts: 7
Joined: 04/04/2011, 13:41

Re: fans always on

Postby Kizikhi » 06/04/2011, 13:46

Woulouf wrote:
I think so but i 've never tested this option.

It could be useful to manage noise fan.

I know that even if i put my netbook in silent mode, speedfan will automatically increase if CPU Temp is too high, at least above a certain threshold.

You are absolutely right, always when you put it in silent mode then it will automatically increase speedfan, and never decrease it.

Has already passed two days like I'am testing the fan and it realy works perfectly like in Windows, like it should work. There is solution which I've found observing the fan these two days.

The Solution:

    Step 1. You should turn on cycle mode in terminal by this command

    Code: Select all

    samsung-tools --cpu cycle
    Step 2. It's a very important moment, without doing this step the fan woun't work in the cycle mode!
    Open Samsung Tools Preferences from your menu, then click on System service tab and choose Normal from CPU fan listbox.

    Step 3. Done! Now you can close the Samsung Tools Preferences and it will work properly (increase speedfan and decrease it when it's necessary). Just wait a little and you will see that your fan is working as it should. :)


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: No registered users and 3 guests