Problems after installing Samsung-tools

Discussions about Linux installation and configuration on Samsung laptops
Aboe
Newbie
Newbie
Posts: 3
Joined: 27/03/2010, 3:29

Problems after installing Samsung-tools

Postby Aboe » 27/03/2010, 3:46

Hello,

I have a problem with my Samsung R510 AS05 with a 9200m GS.
After installing Samsung-tools and easy-slow-down-manager from your Lucid ppa and setting acpi_backlight=vendor in grub, I get a white screen with vertical strips in it.
It only happens when I activate the Nvidia-drivers. I did a full reinstall of ubuntu 9.10 and it didn't help. When I use the open-source drivers or windows the problem dousn't appear.
I am also not able to boot the live-cd of Lucid Beta 1.
I am using karmic with kernel 2.6.32

Thanks for the Help

User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: Problems after installing Samsung-tools

Postby voria » 27/03/2010, 9:23

I'm not sure what is causing your problem, probably it's the 'samsung-backlight' kernel module which is intended to works with intel video cards only.
Initially both the 'easy-slow-down-manager' and 'samsung-backlight' kernel modules were provided by the same package from the repository, I've now split them in 2 separate packages.

If I'm right, your problem should be fixed now by installing only the 'easy-slow-down-manager' package.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

Aboe
Newbie
Newbie
Posts: 3
Joined: 27/03/2010, 3:29

Re: Problems after installing Samsung-tools

Postby Aboe » 27/03/2010, 10:26

Nope, didn't work. As I suspected because a full reinstall of ubuntu also didn't work.
I also have the problem when using the nouveau drivers (lucid live cd).

Could those modules have alterd somthing on hardware-level (bios, ...)?

User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: Problems after installing Samsung-tools

Postby voria » 27/03/2010, 10:44

No, nothing is modified at hardware level.
And if this was the case you would have had problems with karmic too.

Instead, I think something in the Lucid's current status has broken support for your model.
Since Lucid is yet under heavy development and things change very fast, I suggest to file a new bug report on Launchpad against nouveau or/and nvidia-graphics-drivers, if the problem has not yet been reported.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

Aboe
Newbie
Newbie
Posts: 3
Joined: 27/03/2010, 3:29

Re: Problems after installing Samsung-tools

Postby Aboe » 27/03/2010, 14:40

It also happens after a fresh install of karmic when I enable the binairy drivers.
This worked before and now it doesn't.

User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: Problems after installing Samsung-tools

Postby voria » 28/03/2010, 19:07

I'm pretty sure this is a software problem. If it was hardware related, you would have noticed it even with windows. What nvidia driver are you using? Have you tried a different version?
Also, are you using non-default options on the GRUB kernel command line? Try to remove the "acpi_backlight=vendor" option.
And attach here the output of the 'dmesg' command and the file '/var/log/xorg.0.log'.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: No registered users and 1 guest