N210 Plus - Boradcom Wireless not working - Ubuntu 10.04

Discussions about Linux installation and configuration on Samsung laptops
Post Reply
Posts: 1
Joined: 31/08/2010, 13:18

N210 Plus - Boradcom Wireless not working - Ubuntu 10.04

Post by Timmy » 31/08/2010, 14:53


I have recently bought a Samsung N210 Plus and tried to install Ubuntu 10.04 Netbook Remix on it. Everything else seems to be working fine, but I encountered serious problems while trying to get the wireless drivers to work. My version of the notebook is shipped with a broadcom chip for wireless, whereby most models seem to have either a realtek chip or a chip from a third vendor (which I can't remember right now).

I've tried regular fixes:

Installing the package via synaptic (bcmwl-kernel-source)

Installing the same package manually from http://www.broadcom.com/support/802.11/linux_sta.php

Installing the same package with additional instructions as described here:


Tried another thing as described here at the end of the page:


Tried to install older driver package as instructed here:

http://polach.cc/howto-fix-broadcom-wif ... lucid-lynx

(Package refused to build.)

Most of the solutions listed further down below on the list here:


And I tried Ndiswrapper. It failed to load the drivers even if the files should be right and the program recognized the wireless.


As far as I've understood, the problem seems to be with WPA&WPA2 encryption. The wireless detects the network but it isn't able to log onto the network. The network at least is fully functionable; the same computer logs in Windows7 without problems to the same network.

Is someone experiencing the same kind of problems and is there a fix for it?

Any help will be appreciated - I am not the biggest Windows enthusiast on the world, but if wireless doesn't work, a netbook doesn't have much of a point.

Thanks in advance!


Post Reply