Backlight doesn't work with latest Maverick kernel

Discussions about Linux installation and configuration on Samsung laptops
DervishD
Supporter
Supporter
Posts: 4
Joined: 13/10/2010, 13:07

Backlight doesn't work with latest Maverick kernel

Postby DervishD » 09/12/2010, 0:57

Hi :)

Latest Maverick kernel, namely 2.6.35-24, prevents backlight control to work in my N150+ Samsung netbook.
I've manually modprobe'd the modules with debug=1 but I haven't noticed anything weird :?

To date, I've been using the modules installed with voRia kernels with latest Ubuntu kernels without problems.

Should I wait for the next voRia kernel or is there anything I can do to fix the issue? Right now I'm just booting with the voRia kernel, ignoring the kernel update.

Thanks!

Raúl

Lolo
Supporter
Supporter
Posts: 8
Joined: 01/05/2010, 8:16

Re: Backlight doesn't work with latest Maverick kernel

Postby Lolo » 17/12/2010, 22:40

I have exactly the same problem for over a week on my N210 and the screen is now bleak.
Voria thank you if you could do something for us

Ain
Newbie
Newbie
Posts: 7
Joined: 14/04/2010, 10:38

Re: Backlight doesn't work with latest Maverick kernel

Postby Ain » 20/12/2010, 15:56

Same problem for me.
No one of my attempts worked to solve so I just boot with the previous kernel.

Drake
Newbie
Newbie
Posts: 12
Joined: 21/12/2010, 15:12

Re: Backlight doesn't work with latest Maverick kernel

Postby Drake » 21/12/2010, 15:21

Same problem on NF310. :(

Steph
Supporter
Supporter
Posts: 5
Joined: 23/06/2010, 20:10

Re: Backlight doesn't work with latest Maverick kernel

Postby Steph » 21/12/2010, 16:40

Same problem on N220 and N150 :(

Regards

Drake
Newbie
Newbie
Posts: 12
Joined: 21/12/2010, 15:12

Re: Backlight doesn't work with latest Maverick kernel

Postby Drake » 21/12/2010, 17:40

Just filed a bug report: https://bugs.launchpad.net/samsung-tools/+bug/693071
Did anybody discover source code for building samsung-backlight?

Drake
Newbie
Newbie
Posts: 12
Joined: 21/12/2010, 15:12

Re: Backlight doesn't work with latest Maverick kernel

Postby Drake » 22/12/2010, 13:39

Adding

Code: Select all

acpi_backlight=vendor

to the kernel's parameter list in your bootloader should do the trick.
For some reason, in 2.6.35-24 the ACPI driver starts feeling responsible for controlling the backlight.

In case of trouble when updating the kernel, backlight can also be controlled by manually writing numbers (0-7) to /sys/class/backlight/samsung/brightness (you may have to save several times to reach your target level of brightness).

Lolo
Supporter
Supporter
Posts: 8
Joined: 01/05/2010, 8:16

Re: Backlight doesn't work with latest Maverick kernel

Postby Lolo » 22/12/2010, 13:47

Drake wrote:Adding

Code: Select all

acpi_backlight=vendor

to the kernel's parameter list in your bootloader should do the trick.
For some reason, in 2.6.35-24 the ACPI driver starts feeling responsible for controlling the backlight.

In case of trouble when updating the kernel, backlight can also be controlled by manually writing numbers (0-7) to /sys/class/backlight/samsung/brightness (you may have to save several times to reach your target level of brightness).
you know, for many peoples, it's more easy to install Windows ! ;D

Drake
Newbie
Newbie
Posts: 12
Joined: 21/12/2010, 15:12

Re: Backlight doesn't work with latest Maverick kernel

Postby Drake » 22/12/2010, 22:26

I'm slightly aware of this fact.
Nevertheless, it might help some fanatic open source lover and Windows hater (I was told that Linux users sometimes match this character). ;)

Lolo
Supporter
Supporter
Posts: 8
Joined: 01/05/2010, 8:16

Re: Backlight doesn't work with latest Maverick kernel

Postby Lolo » 22/12/2010, 22:34

sometimes yes .... but they are fewer and fewer ;D

eth1cal
Newbie
Newbie
Posts: 1
Joined: 22/12/2010, 22:29

Re: Backlight doesn't work with latest Maverick kernel

Postby eth1cal » 22/12/2010, 22:58

Many many thanks Drake : ) works like a charm!

Here's how you change the kernel parameters. I am running Ubuntu 10.10 Netbook Edition on Samsung N210, so my bootloader is GRUB2.

Open the terminal...

1) Type "sudo nano /etc/default/grub" (replace nano with your favourite text editor, if needed)
2) Add "acpi_backlight=vendor" to the GRUB_CMDLINE_LINUX_DEFAULT parameters, so that...

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

...or something similar becomes...

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor"

3) Close nano (CTRL+X) and save changes (Y)
4) Type "sudo update-grub2"
5) Type "sudo reboot"

In case you still have GRUB bootloader (instead of GRUB2), I believe you have to add "acpi_backlight=vendor" to /boot/grub/menu.lst, but unfortunately I don't have any system running with GRUB anywhere near, so I am unable to give you the full how-to. Google knows, I'm sure.

Lolo
Supporter
Supporter
Posts: 8
Joined: 01/05/2010, 8:16

Re: Backlight doesn't work with latest Maverick kernel

Postby Lolo » 22/12/2010, 23:47

Thank you Drake and eth1cal for your "how to"...

but it doesn't work for me (N210 & classical ubuntu 10.10)
I will wait for again for few days and maybe make a downgrade toward ubuntu 10.04 LTS ;)

Drake
Newbie
Newbie
Posts: 12
Joined: 21/12/2010, 15:12

Re: Backlight doesn't work with latest Maverick kernel

Postby Drake » 23/12/2010, 0:05

Try setting it manually:
1) Type

Code: Select all

sudo nano /sys/class/backlight/samsung/brightness

=> The file should contain a single number (0-7).
2) Type a small number (replacing the old one), e.g. "1" and save several times (CTRL+O, ENTER).
=> Your screen should lower the brightness step by step.

Posting the output of the following command may also help to analyse your specific problem:

Code: Select all

ls /sys/class/backlight


Before wearing sun glasses, try adjusting the brightness at the GRUB screen.

Lolo
Supporter
Supporter
Posts: 8
Joined: 01/05/2010, 8:16

Re: Backlight doesn't work with latest Maverick kernel

Postby Lolo » 23/12/2010, 0:55

At the same time, an update of Voria's deposits, has changed for the maximum luminosity (and it's better for me for now)

As you suggest, I can manually adjust the brightness lower step by step without any problems. ;)

And here is the result of the code required:
acpi_video0 samsung


EDIT : I tried the eth1cal's method again and after the reboot, it works perfectly now, so a big thank you both for your help and your patience !

Drake
Newbie
Newbie
Posts: 12
Joined: 21/12/2010, 15:12

Re: Backlight doesn't work with latest Maverick kernel

Postby Drake » 23/12/2010, 1:49

The presence of the "acpi_video0" directory is a strong indication of the ACPI driver problem solved by the fix mentioned above. After adding "acpi_backlight=vendor" to your kernel's paramter list it must not (well, it should not) exist.
You might want to check if applying the parameter was successful by running

Code: Select all

sudo dmesg | grep acpi_backlight

Output should look like

Code: Select all

[0.000000] Command Line: ... quiet splash acpi_backlight=vendor
[0.000000] Kernel command line: ... quiet splash acpi_backlight=vendor

If there is no output, the parameter was not applied successfully. You may want to check the GRUB_CMDLINE_LINUX_DEFAULT string, rerun update-grub2 and reboot first.
If there is an output... well, one step at a time. Feel free to post it. :D

EDIT: I am glad to read about your success. :)


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: Google [Bot] and 1 guest