Backlight doesn't work with latest Maverick kernel

Discussions about Linux installation and configuration on Samsung laptops
jazz
Newbie
Newbie
Posts: 6
Joined: 25/12/2010, 16:44

Re: Backlight doesn't work with latest Maverick kernel

Postby jazz » 19/03/2011, 17:12

dundee wrote:Hello,
I'm owner of Samsung NP-N150-JP01PL.
In my case after installing samsung-backlight and samsung-tools I use following sollution with success:

1. edit /etc/default/grub

Code: Select all

sudo nano /etc/defautl/grub

2. change line from

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

3. update grub

Code: Select all

sudo update-grub2

4. create file /etc/modprobe.d/samsung-backlight.conf

Code: Select all

sudo nano /etc/modprobe.d/samsung-backlight.conf

5. insert into this file following line and save it

Code: Select all

options samsung_backlight use_sabi=0 force=1

6. reboot the system

This solution was checked under GNOME and KDE and in both it works perfectly.
Naturally you can use your favourite text editor instead of nano.


I could only set the brightness to the min or max with the backlight keys on my NF-310, I tried everything on this thread, with no success, but with your solution it finally works! Thanks!

User avatar
Woulouf
Supporter
Supporter
Posts: 51
Joined: 05/03/2011, 12:32
Location: France

Re: Backlight doesn't work with latest Maverick kernel

Postby Woulouf » 23/03/2011, 9:12

jazz wrote:
dundee wrote:Hello,
I'm owner of Samsung NP-N150-JP01PL.
In my case after installing samsung-backlight and samsung-tools I use following sollution with success:

1. edit /etc/default/grub

Code: Select all

sudo nano /etc/defautl/grub

2. change line from

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

3. update grub

Code: Select all

sudo update-grub2

4. create file /etc/modprobe.d/samsung-backlight.conf

Code: Select all

sudo nano /etc/modprobe.d/samsung-backlight.conf

5. insert into this file following line and save it

Code: Select all

options samsung_backlight use_sabi=0 force=1

6. reboot the system

This solution was checked under GNOME and KDE and in both it works perfectly.
Naturally you can use your favourite text editor instead of nano.



I could only set the brightness to the min or max with the backlight keys on my NF-310, I tried everything on this thread, with no success, but with your solution it finally works! Thanks!


And you don't encounter issues like flickering screen with brightness level going up and down quickly ?

Thanks
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753

jazz
Newbie
Newbie
Posts: 6
Joined: 25/12/2010, 16:44

Re: Backlight doesn't work with latest Maverick kernel

Postby jazz » 26/03/2011, 14:56

Woulouf wrote:And you don't encounter issues like flickering screen with brightness level going up and down quickly ?

Not anymore! Now the screen dims correctly after some time of inactivity.

minj
Newbie
Newbie
Posts: 1
Joined: 26/03/2011, 20:19

Re: Backlight doesn't work with latest Maverick kernel

Postby minj » 26/03/2011, 20:23

dundee wrote:Hello,
I'm owner of Samsung NP-N150-JP01PL.
In my case after installing samsung-backlight and samsung-tools I use following sollution with success:

1. edit /etc/default/grub

Code: Select all

sudo nano /etc/defautl/grub

2. change line from

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

3. update grub

Code: Select all

sudo update-grub2

4. create file /etc/modprobe.d/samsung-backlight.conf

Code: Select all

sudo nano /etc/modprobe.d/samsung-backlight.conf

5. insert into this file following line and save it

Code: Select all

options samsung_backlight use_sabi=0 force=1

6. reboot the system

This solution was checked under GNOME and KDE and in both it works perfectly.
Naturally you can use your favourite text editor instead of nano.


Confirmed on NF310.

Although after some fiddling around with power state, lid and suspend/hibernate cycles I managed to make plugging cable out cause 'closed lid' action, which is very annoying if it is set to suspend. After a proper reboot the glitch didn't repeat itself though. I don't really want to reproduce it ;)

Sam66
Newbie
Newbie
Posts: 2
Joined: 03/03/2011, 20:54

Re: Backlight doesn't work with latest Maverick kernel

Postby Sam66 » 01/04/2011, 21:41

Thank you everybody !

I have tried to add the command acpi_backlight=vendor in my Grub and it's all right, I have recovered my Fn brightness buttons in the 2.6.35-28 kernel.

Great !

terry
Newbie
Newbie
Posts: 14
Joined: 02/05/2010, 12:05
Location: Sydney, Australia
Contact:

Re: Backlight doesn't work with latest Maverick kernel

Postby terry » 04/04/2011, 2:04

Passing the kernel parameter acpi_backlight=vendor does the trick on N-148.

However, I did see weird issues running on battery, after idling for a few seconds system tries to adjust the brightness itself back and forth flickering for 20-30 times, unchecking the dim display when idle fixed it.

Good to see it's been such a long post, in fact I haven't used my netbook for a while...

pawel115
Newbie
Newbie
Posts: 1
Joined: 15/04/2011, 8:50

Re: Backlight doesn't work with latest Maverick kernel

Postby pawel115 » 15/04/2011, 9:24

I am total newbie to Ubuntu i did all above instructions and nothing the only change that i see is that when i press Fn + up/down brightness level doesnt show like it did before i have samsung n145

robbie66
Newbie
Newbie
Posts: 2
Joined: 29/06/2011, 14:58

Re: Backlight doesn't work with latest Maverick kernel

Postby robbie66 » 29/06/2011, 15:49

I have posted a new thread because I find all this tech stuff really hard to follow, is there a Dummies guide??!!

viewtopic.php?f=3&t=860&hilit=n220+screen

lfc84
Newbie
Newbie
Posts: 1
Joined: 12/07/2013, 21:42

Re: Backlight doesn't work with latest Maverick kernel

Postby lfc84 » 12/07/2013, 21:45

this works on samsung n210plus

Linux N150P-N210P-N220P 3.2.0-49-generic-pae #75-Ubuntu SMP Tue Jun 18 18:00:21 UTC 2013 i686 i686 i386 GNU/Linux


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: Google [Bot] and 1 guest