Fan control issue with Samsung NP270E5E-X04IT

Discussions about Linux installation and configuration on Samsung laptops
de.marduk89
Newbie
Newbie
Posts: 3
Joined: 24/11/2013, 17:06

Fan control issue with Samsung NP270E5E-X04IT

Postby de.marduk89 » 24/11/2013, 17:25

Good Sunday to everyone!
Mine isn't so good due to my laptop, a Samsung NP270E5E-X04IT.
I installed on it Xubuntu 13.04 in September and, after I told him about issues with the fans control, a friend of mine told me about samsung-tools. I installed it but also with this tool, my cpu's fans are too fast and too noisy on Linux.
Unlikely I discovered that samsung-tools on my laptop doesn't manages the fan speed. I'd tried other tools like fancontrol to make this but, due to pwmconfig that doesn't find any pwm sensor, I can't make it works.

What should I do to make work samsung-tools also for my fans? Or there is another options?

Thank you in advance and please tell me if you want other information about this problem

de.marduk89
Newbie
Newbie
Posts: 3
Joined: 24/11/2013, 17:06

Re: Fan control issue with Samsung NP270E5E-X04IT

Postby de.marduk89 » 04/12/2013, 21:27

After 10 days I haven't any update.
I tried to upgrade my Xubuntu to version 13.10, but nothing has changed.
I haven't any idea of what to do. The fan isn't too noisy but this problem is quite annoying.

Any suggestions?

Thanks

neb
Newbie
Newbie
Posts: 3
Joined: 27/11/2013, 13:53

Re: Fan control issue with Samsung NP270E5E-X04IT

Postby neb » 05/12/2013, 0:04

Hi,

I'm guessing you installed linux in EFI mode. It appears that the samsung-laptop module is not loaded when the kernel finds an EFI installation.

The most obvious thing to do, if you want fan control now, is to reinstall linux in BIOS mode. Otherwise you can try and wait until someone fixes the issue on the kernel itself, but don't expect too much - even though I, myself, have actually decided to wait for it.

de.marduk89
Newbie
Newbie
Posts: 3
Joined: 24/11/2013, 17:06

Re: Fan control issue with Samsung NP270E5E-X04IT

Postby de.marduk89 » 05/12/2013, 8:24

Hi!

I think you're right.
I'd installed Ubuntu in Bios mode but, being this in dual boot with Windows 8 preinstalled, I had to use boot-repair to fix the boot of both the systems.
Now my Linux version starts in Uefi mode.

I think I'll wait with you because I'm to lazy to reinstall both the systems in Bios mode :D
Let's hope for a solution not too far from now.

Thanks for your reply

vonTrubka
Newbie
Newbie
Posts: 1
Joined: 09/01/2016, 12:46

Re: Fan control issue with Samsung NP270E5E-X04IT

Postby vonTrubka » 09/01/2016, 13:03

neb wrote:Hi,

I'm guessing you installed linux in EFI mode. It appears that the samsung-laptop module is not loaded when the kernel finds an EFI installation.

The most obvious thing to do, if you want fan control now, is to reinstall linux in BIOS mode. Otherwise you can try and wait until someone fixes the issue on the kernel itself, but don't expect too much - even though I, myself, have actually decided to wait for it.


Hi, I am really desperate to solve fan noise problem on my laptop. I tried many ways and they all failed. I would like to try to reinstall my xubuntu in BIOS mode, but I don't really know what does it mean. Can anyone explain how to do it please?


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: No registered users and 1 guest