Samsung tools in 16.04.1 LTS

Discussions about Linux installation and configuration on Samsung laptops
Post Reply
ectatomma
Newbie
Newbie
Posts: 1
Joined: 07/02/2017, 18:06

Samsung tools in 16.04.1 LTS

Post by ectatomma » 07/02/2017, 18:56

Hi, I just installed samsung tools in Xubuntu 16.04.1 LTS and want to let all know the problems I had and how I fixed them.

Edit: I just found a repo that made samsung-tools available for xenial:

Code: Select all

sudo add-apt-repository ppa:mystic-mirage/loms
sudo apt-get update
Please, ingore the rest of the post.


After adding the repository, I had an error complaining about no finding the files for Xenial, so I went to the Xubuntu (or Ubuntu) settings, then openend "Software and updates" and configured the repo to use trusty instead of xenial
[attachment=0]Screenshot_2017-02-07_13-22-23.png[/attachment]
Then I updated the repos with

Code: Select all

sudo apt-get update
and problem solved, I was able to install samsung-tools.

Next, when I tried to open the program, nothing happened, so I opened a terminal and ran the program. I had the next error:

Code: Select all

eduar@samsungNP305U:~$ samsung-tools
Traceback (most recent call last):
  File "/usr/bin/samsung-tools", line 28, in <module>
    import dbus
ImportError: No module named dbus
After some research using Google, I found the culprit was a missing dependency: python-dbus, which also requires python-gi and phyton-qt4-dbus, so I installed them:

Code: Select all

sudo apt-get install python-dbus python-gi phyton-qt4-dbus
After that, the program ran and I'm testing how it works, I'll let you now.[/size]
Attachments
Screenshot_2017-02-07_13-22-23.png

JoseFontes
Newbie
Newbie
Posts: 1
Joined: 17/04/2017, 16:38

Re: Samsung tools in 16.04.1 LTS

Post by JoseFontes » 18/04/2017, 11:01

Excellent, thanks ectatomma. I'm installing samsung tools now.
I approve of this Gynectrol.

Sebastiao
Newbie
Newbie
Posts: 1
Joined: 22/04/2017, 23:03

Re: Samsung tools in 16.04.1 LTS

Post by Sebastiao » 22/04/2017, 23:08

I'm having a problem in an similar environment, probably with dependencies.

There is a way to install samsung-tools with dependencies ?

When I run samsung-tools from prompt I have the following messages:

Code: Select all

Traceback (most recent call last):
  File "/usr/bin/samsung-tools", line 28, in <module>
    import dbus
  File "/usr/lib/python2.7/dist-packages/dbus/__init__.py", line 103, in <module>
    from dbus._dbus import Bus, SystemBus, SessionBus, StarterBus
  File "/usr/lib/python2.7/dist-packages/dbus/_dbus.py", line 39, in <module>
    from dbus.bus import BusConnection
  File "/usr/lib/python2.7/dist-packages/dbus/bus.py", line 39, in <module>
    from dbus.connection import Connection
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 37, in <module>
    from dbus.proxies import ProxyObject
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 34, in <module>
    from dbus._expat_introspect_parser import process_introspection_data
  File "/usr/lib/python2.7/dist-packages/dbus/_expat_introspect_parser.py", line 26, in <module>
    from xml.parsers.expat import ParserCreate
  File "/usr/lib/python2.7/xml/parsers/expat.py", line 4, in <module>
    from pyexpat import *
ImportError: /usr/lib/python2.7/lib-dynload/pyexpat.x86_64-linux-gnu.so: undefined symbol: XML_SetHashSalt
uname -a

Code: Select all

Linux noti-tiao 4.4.0-72-generic #93-Ubuntu SMP Fri Mar 31 14:07:41 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[]'s

Post Reply