HOWTO: Use the repository on *buntu 12.04 LTS and above

Discussions about Linux installation and configuration on Samsung laptops
Tarnox
Newbie
Newbie
Posts: 1
Joined: 02/01/2018, 12:03

Re: HOWTO: Use the repository on *buntu 12.04 LTS and above

Post by Tarnox » 02/01/2018, 12:08

Hi. Voria!

I've installed samsung-tools for my Ubuntu 16.04 LTS on Samsung NP900X5N-X01US laptop.
However, when attempting to see status of any of the devices, terminal holds for a while before spitting this:

Code: Select all

samsung-tools -b status
Traceback (most recent call last):
  File "/usr/bin/samsung-tools", line 782, in <module>
    main()
  File "/usr/bin/samsung-tools", line 732, in main
    Backlight(options.backlight).apply()
  File "/usr/bin/samsung-tools", line 126, in apply
    result = self.__status()
  File "/usr/bin/samsung-tools", line 69, in __status
    return self.interface.IsEnabled()
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Do you have any clues on fixing this error?

User avatar
voria
Administrator
Administrator
Posts: 1382
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

Re: HOWTO: Use the repository on *buntu 12.04 LTS and above

Post by voria » 03/01/2018, 12:14

I've just tested latest Samsung Tools with Ubuntu 16.04 LTS in a virtual machine, and everything works as expected.

My only guess for your problem is that you installed it manually from the source code, and some dependency is missing.
Try the .deb file for Ubuntu 17.10, it works just fine for Ubuntu 16.04 LTS also. Just grab it from the repository and install it in the usual way.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

User avatar
Woulouf
Supporter
Supporter
Posts: 52
Joined: 05/03/2011, 12:32
Location: France

Re: HOWTO: Use the repository on *buntu 12.04 LTS and above

Post by Woulouf » 05/01/2018, 6:57

Thank you Voria for keeping this project updated.

I can't test now because my old N150 samsung need a lcd screen replacement ::)
I'll bring feedback when done.

Anyway, i wish you an happy New Year !
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic http://www.voria.org/forum/viewtopic.php?p=5753#p5753

Post Reply