[NC10] How to fix the sensitivity of the touchpad

Discussions about Linux installation and configuration on Samsung laptops
User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: [NC10] How to fix the sensitivity of the touchpad

Postby voria » 08/04/2009, 10:07

booyau wrote:I installed all of the packages from the modified NC10 repository, including xserver-xorg-input-synaptics. The first thing I noticed was that the overall sensitivity of my trackpad decreased significantly. One swipe across the trackpad now goes only about 2 inches across the screen. I fooled with the Gnome Mouse settings, but sensitivity doesn't seem to do anything. If I turn acceleration all the way up to max, the trackpad is usable again, but difficult due to the high acceleration. It seems mostly OK as gdm comes up, but once I login and Gnome starts, the sensitivity drops by about half.


The only difference between the original package and the custom one is the reduced vertical sensitivity (and only the vertical one). With the default options my touchpad works "just right", ie by moving my finger from left to right and up to down on the whole touchpad makes the pointer cover exactly the whole desktop area on the screen. Anyway, I never used the gnome mouse settings, so I don't know how it works. However, if the touchpad works good on gdm, then gnome mouse settings has probably messed up some settings for your session.

booyau wrote:I checked the .fdi file, and it says VertAdjustmentFactor is at 0.6 - i assume you changed your default value?


Yes, the default value is 0.6 now, I'll update the main post to reflect the change.

booyau wrote:However, even if I change the factor to 4 in the.fdi file or use synclient, it doesn't have any effect on the pointer.


That's strange. Did you restarted the hal daemon and the xserver to use the new settings from the .fdi file?
If you want to change settings on the fly, you have to use the 'synclient' utility.


booyau wrote:FYI: I'm running kernel 2.6.28-8. I'm not sure if that makes any difference. I believe that's the kernel that my system thinks is the most "up to date".


Are you using jaunty? If so, the latest available kernel from official repositories is the 2.6.28-11. On intrepid, the latest one is the 2.6.27-14 (from proposed repositories).
The 'linux-backports-modules' and 'alsa-drivers' packages on my repository are for these kernels only.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

ossas81
Newbie
Newbie
Posts: 19
Joined: 07/04/2009, 3:51

RE: [NC10] How to fix the sensitivity of the touchpad

Postby ossas81 » 08/04/2009, 19:48

I also had the huge-drop in overall "speed" of the trackpad when I ran the nc10 repository. I am on 2.6.27-14 on Intrepid.

I tried updating the .fdi and the xorg.conf with parameters from varying websites/wikis for Ubuntu on Samsung, but with no luck. Maybe I need to play with the .fdi a little more. The only way to fix the problem (as booyau says) is to change the Gnome mouse settings.

The only downside to this is that when I use my bluetooth mouse, it is way too fast, and I need to go in there and slow it down again. I assume I can probably just change .fdi settings (or xorg.conf) for "mouse" instead of "trackpad".

User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: [NC10] How to fix the sensitivity of the touchpad

Postby voria » 09/04/2009, 11:15

If you use my custom synaptics package you should not use the xorg.conf options as described in ubuntu nc10 wiki page.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

kadrach
Newbie
Newbie
Posts: 30
Joined: 14/03/2009, 21:59

RE: [NC10] How to fix the sensitivity of the touchpad

Postby kadrach » 10/04/2009, 18:52

Don't touch the xorg.conf file!

As voria said, the file is not necessary anymore, but it WILL override hal settings when it is used. The best thing to do is to change/create an fdi file

Also, the changes voria made only affect the synaptics touchpad (the change is made in the corresponding fdi file, which hal loads for this type of touchpad. For a bluetooth mouse, you will need to: either change the corresponding fdi or set gnome/kde mouse settings. Note that the latter will affect ALL input pointers, so if you use a touchpad + external mouse, only edit the fdi files.

ossas81
Newbie
Newbie
Posts: 19
Joined: 07/04/2009, 3:51

RE: [NC10] How to fix the sensitivity of the touchpad

Postby ossas81 » 10/04/2009, 19:46

ok. I commented out the options in xorg.conf under synaptics, and everything works great now (both touchpad and mouse sensitivities are ok)

is there anything special I need to do to get syndaemon to work properly (disable touchpad while typing)? that doesn't seem to work with these updates.
Last edited by ossas81 on 10/04/2009, 19:51, edited 1 time in total.

kadrach
Newbie
Newbie
Posts: 30
Joined: 14/03/2009, 21:59

RE: [NC10] How to fix the sensitivity of the touchpad

Postby kadrach » 10/04/2009, 20:15

You need to enable SHMConfig

/etc/hal/fdi/policy/shmconfig.fdi

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="input.x11_driver" string="synaptics">
      <merge key="input.x11_options.SHMConfig" type="string">True</merge>
    </match>
  </device>
</deviceinfo>


With this, it should work.

ossas81
Newbie
Newbie
Posts: 19
Joined: 07/04/2009, 3:51

RE: [NC10] How to fix the sensitivity of the touchpad

Postby ossas81 » 11/04/2009, 9:54

that doesn't seem to work. (there originally wasn't a shmconfig.fdi there, so i made one). there was a preferences.fdi in that folder, and i added the lines in there too, with no luck. when I had shmconfig turned on in the xorg.conf earlier, it also didn't work. also putting it in the 11-x11-synaptics.fdi didn't work. any other way to enable it? maybe i'm not merging it into the files correctly.

I have the correct commands for syndaemon in startup manager, because it was working earlier before kernel updates.

User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: [NC10] How to fix the sensitivity of the touchpad

Postby voria » 11/04/2009, 10:01

If you use my package the SHMConfig option is enabled by default.
What is the output of the 'synclient -l' command?
If it is a list of options with their values, then SHMConfig is already enabled.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

MichaelW
Newbie
Newbie
Posts: 1
Joined: 11/04/2009, 13:15

RE: [NC10] How to fix the sensitivity of the touchpad

Postby MichaelW » 11/04/2009, 15:02

Hello. Just thought I'd say, I installed your wonderful repository and had the same trouble - touchpad was no different. Then I deleted most of my xorg.conf file and that fixed the problem. I had previously added a section for the touchpad, which someone said would help but which didn't. Now my touchpad is very lively and can draw circles. Many thanks.

ossas81
Newbie
Newbie
Posts: 19
Joined: 07/04/2009, 3:51

RE: [NC10] How to fix the sensitivity of the touchpad

Postby ossas81 » 12/04/2009, 3:39

'synclient -l' shows the options, etc. I am running the syndaemon as I did before I ran the repository updates (it previously worked). I re-did the syndaemon in sessions manager.
if I type 'syndaemon -i 1 -d' in terminal, nothing happens, and the touchpad is still active while typing.

re-installing the repo. package that had syndaemon didn't fix it either. Weird..everything else is working fine.
Last edited by ossas81 on 12/04/2009, 3:49, edited 1 time in total.

User avatar
voria
Administrator
Administrator
Posts: 1378
Joined: 12/02/2009, 18:08
Location: Italy
Contact:

RE: [NC10] How to fix the sensitivity of the touchpad

Postby voria » 12/04/2009, 9:39

I'm using syndaemon all the time and it works fine here, I don't know why it does not work for you.
Start it from a shell without the '-d' option and check if it exits with any error message.
Image
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!

ossas81
Newbie
Newbie
Posts: 19
Joined: 07/04/2009, 3:51

RE: [NC10] How to fix the sensitivity of the touchpad

Postby ossas81 » 12/04/2009, 18:53

syndaemon in shell is fine... it even displays "enable" and "disable" depending on if I'm typing in another window. it just doesn't actually disable the trackpad. I commented out a few more lines under my xorg.conf in synaptics with no luck. I'm going to look through my .fdi to see if there's anything weird...

ossas81
Newbie
Newbie
Posts: 19
Joined: 07/04/2009, 3:51

RE: [NC10] How to fix the sensitivity of the touchpad

Postby ossas81 » 16/04/2009, 2:30

OK problem solved: it all had to do with my xorg.conf.

even though I had commented out the touchpad options, something in there was preventing syndaemon/synclient from working properly. I had kept the xorg.conf mostly the same (from the nc10 ubuntu wiki), because removing too much would cause low-display mode. I finally just deleted xorg.conf, and then re-added just a few items (the display/monitor devices, etc), and now everything works great.

Vox
Newbie
Newbie
Posts: 10
Joined: 21/04/2009, 8:58

RE: [NC10] How to fix the sensitivity of the touchpad

Postby Vox » 21/04/2009, 9:09

Hello,
I've installed your synaptic's package and I've lost my horizontal scroll...
What can i do ?

Thanks.

kadrach
Newbie
Newbie
Posts: 30
Joined: 14/03/2009, 21:59

RE: [NC10] How to fix the sensitivity of the touchpad

Postby kadrach » 21/04/2009, 10:25

Voria, maybe you should put a giant red "Don't use xorg.conf" somewhere.

@vox: is it enabled in the fdi file (check previous posts)?


Return to “Linux On My Samsung”

Who is online

Users browsing this forum: No registered users and 2 guests