Page 1 of 1

[DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Posted: 25/01/2015, 8:55
by luke1337
I've ported easy-slow-down-manager for Linux kernel 3.x.

Check this out and tell me if it doesn't work.

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.0

Posted: 02/03/2015, 22:14
by puntigamer
Hi! Thank you from porting this!

My problem is (Ativ Book 7), that after "silencing" the fan/cpu and use it for a while (even browsing starts the fan), it never goes back to the silence state, so I have to echo every time when I will silence it again. Why is this? It's not a good solution the echo 1 to esdm all the time, I guess :)

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Posted: 24/01/2016, 18:38
by savimisha
Where is the attachment esdm.zip? It was here yesterday(

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Posted: 24/01/2016, 19:16
by voria
There have been some problems during the forum migration, almost all of the old attachments have been corrupted. :(
Luckily, not this one. Here it is:

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Posted: 17/04/2016, 12:01
by luke1337
Hi, this is the author of easy-slow-down-manager for Linux 3.x.

I've just confirmed that the attachment the admin has posted didn't get corrupted :)

By the way, I wonder if this works for Linux 4.x? I haven't tested it yet, since I haven't got a Linux 4.x kernel yet..

(The sure thing is, it does work on Ubuntu 14.04 LTS - the one I currently am using :P)

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Posted: 07/06/2016, 12:05
by NitroNilz
I just tried it on a 4.5* kernel, but didn't get it working. I'm no x-pert and the error is probably that by trying to follow your instructions I downloaded the source of the 3.16-kernel while using 4.5.
Is there a way I could properly test it on my kernel?

Here's the trouble:

Code: Select all

# make -C /usr/src/linux-source-3.16 M='pwd' modules
make: Entering directory '/usr/src/linux-source-3.16'

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.


  WARNING: Symbol version dump ./Module.symvers
           is missing; modules will have no dependencies and modversions.

scripts/Makefile.build:44: pwd/Makefile: No such file or directory
make[1]: *** No rule to make target 'pwd/Makefile'.  Stop.
Makefile:1352: recipe for target '_module_pwd' failed
make: *** [_module_pwd] Error 2
make: Leaving directory '/usr/src/linux-source-3.16'

Re: [DL] easy-slow-down-manager for Linux 3.x (Ubuntu >=13.04)

Posted: 09/06/2016, 13:14
by luke1337
NitroNilz wrote:I just tried it on a 4.5* kernel, but didn't get it working. I'm no x-pert and the error is probably that by trying to follow your instructions I downloaded the source of the 3.16-kernel while using 4.5.
Is there a way I could properly test it on my kernel?

Here's the trouble:

Code: Select all

# make -C /usr/src/linux-source-3.16 M='pwd' modules
make: Entering directory '/usr/src/linux-source-3.16'

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.


  WARNING: Symbol version dump ./Module.symvers
           is missing; modules will have no dependencies and modversions.

scripts/Makefile.build:44: pwd/Makefile: No such file or directory
make[1]: *** No rule to make target 'pwd/Makefile'.  Stop.
Makefile:1352: recipe for target '_module_pwd' failed
make: *** [_module_pwd] Error 2
make: Leaving directory '/usr/src/linux-source-3.16'
I haven't checked the 4.x versions yet. Maybe I will port it to 4.x version later ;)

EDIT: I think there's something wrong with your setup according to that error message...maybe the Linux source code tree wasn't configured (by `make oldconfig` or such)?